You should always try to use the latest version.

0.8.14

Windows Installer
Windows Archive
Source Code

0.8.13

Windows Installer
Windows Archive
Source Code

0.8.12

Windows Installer
Windows Archive
Source Code

0.8.11

Windows Installer
Windows Archive
Source Code

0.8.10

Windows Installer
Windows Archive
Source Code

0.8.9

Windows Installer
Windows Archive
Source Code

0.8.8

Windows Installer
Windows Archive
Source Code

0.8.7

Windows Installer
Windows Archive
Source Code

0.8.6

Windows Installer
Windows Archive
Source Code
Puppy Linux Binary

0.8.5

Windows Installer
Windows Archive
Source Code
Puppy Linux Binary

0.8.4

Windows Installer
Windows Archive
Source Code

0.8.3

Windows Installer
Windows Archive
Source Code
Puppy Linux Binary

0.8.2

Windows Installer
Windows Archive
Source Code

0.8.1

Windows Installer
Windows Archive
Source Code

0.8.0

Windows Installer
Windows Archive
Source Code